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Note 

The following pages describe the new features of the current version. All new features apply 

exclusively to SPIRIT, provided the corresponding licensed program sections are available on the 

user’s/customer’s computer. 

 For more information, please refer to the online help. The new features are listed on the start 

page and are linked to the respective chapter, where the feature is explained in detail. 
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Adaptations – Line width 

The line widths are back. 
Description 

The line widths are back and combine a classic function with the new possibilities for SPIRIT 2020. 

Lines can now be wider in the plan to highlight something more clearly. 

You can now use the line width for all SPIRIT 2D objects. The line width is displayed for lines, 

polylines, circles, ellipses etc. in the standard display as well as in the layout display.  

The line width is set, transferred or selected by using the Object Inspector. 

Function 

The line width can be set in the pull-down menu Edit > 

Modify, in the Menu-Navigator Edit > S6 Modify > F9 line 

Weight and the shortcut key [ALT] + [c]. The line width is 

then applied to the drawing object. 

The line width setting in the Object Inspector is new. The line 

width is available under 01. General Settings > Line Type > 

Line width for all line objects. 

Using the standard functions of the object inspector, the line 

width can now be transferred to other objects, used as a 

selection filter for the magic wand and as a further 

properties for the “create similar”. The line widths now adapt dynamically on the drawing surface. In 

the layout display you can now directly see the line width in relation to the set scale. The line width 

property is also saved in the drawing style so that you can keep it in a drawing style like all other 

settings. 

Value 

 The Classic function can now be used again with full functionality. 

 Improved display of line widths on the drawing surface. 

 The line width can be quickly set using the Object Inspector. 

 All functions of the Object Inspector (format brush, create similar and magic wand) are available 

for the line width. 

 Line width can be used in the drawing style. 
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Adaptations – Coloring symbols 

Hilight function now also for symbols. 

Description 

Symbols (*.B12) are useful items that allow you to combine a collection of related content into a 

single object. Symbols can contain a wide range of contents, from details about classic symbols, from 

different specialist planning directions to title blocks or layout content. 

Sometimes it can happen that the entered symbol has to be adjusted later. With SPIRIT 2020, you 

can easily colorize symbols depicted in the drawing. It is no longer necessary to change the color 

directly in the symbol itself. 

Function 

You can work with the symbols as usual. It does not matter 

whether you use the symbols from Explorer, place your own 

symbols in the drawing area or work with TPL catalogs. 

You are probably familiar with the highlight function from 

the references. You can now apply the same to the symbols.  

In the Object Inspector of the selected symbol, the entire 

range of functions for highlighting is now available under 

item 40. Reference. 

First choose whether you want to highlight the selected symbol [Yes / No]. If you select [Yes], the 

color selected under the Color display is transferred to the entire symbol. Fillings are also colored a 

little paler using the selected color. 

The Linetype and Linetype Scale Factor can also be changed this way.  

Value 

 The same symbols can be assigned different colors without having to create a new symbol. 

 To change the color, the symbol does not have to be opened and adjusted as an internal symbol.  
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Adaptations – Symbol variables with values 

Filled symbol variables keep their information. 

Description 

Symbols also have another added function, the symbol variables. These can be used in many 

different ways. Be it as drawing variables in the title block, as stamp or info text or after the DWG / 

DXF import. If block references with variables are imported they will appear in SPIRIT variable as text 

between the @-characters. For example @ViewName@ for the plan name in the title block. 

To make sure that the information from the variables is not lost and remains legible after the symbol 

has been exploded, the contents of the variables are displayed as text in SPIRIT 2020. 

 

The picture shows a symbol with filled symbol variables on the left, in the center of the picture you 

see a explode symbol with the placeholders of the variables in SPIRIT 2019 and on the right the 

exploded symbol with texts in SPIRIT 2020. 

Function 

The contents of the symbol variables will now always be converted directly into text after being 

exploded. The placeholder @ Variable @ is no longer displayed. This is the current standard in SPIRIT. 

You can resolve symbols using the Explode function in the pull-down menu Edit or in the context 

menu of the symbol. 

Value 

 Variable contents will now be retained and cannot get lost.  
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Adaptations – Filter function in the dockable 

dialogs 

Keyword filter for a clear view. 

Description 

A filtered view of all indexes C in the plan list, a view of all layers of level E-01 or all components of 

the type Wall – with the new keyword search in the dockable dialogs and in the file manager this is 

no problem. 

The keyword search can optionally be displayed in the dialogs Layer Manager, View Manager and 

Sheet Manager as well as in the File manager and Reference manager. 

Function 

The search can be started in the active dialog using the key 

combination [CTRL] + [f] or via the context menu of the 

column editing search field.  

The search field for the keywords is then activated and you 

can search for names in the corresponding table.  

The results of the search are then filtered in the tables and 

the non-applicable content is hidden.  

The search is closed and the filter removed with the [ESC] 

key in the active entry of the search field or by clicking on 

the [X]. 

 

Value 

 Quick filter options for the table contents of the different dialogs. 
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Adaptations – Zip and Go 

Pack your drawing more conveniently into one package. 

Description 

The Zip and Go function has completely been revised for SPIRIT 2020 and offers some new functions. 

Zip and Go creates a compressed archive folder with all files belonging to the drawing. In addition to 

the actual drawing file, all external referenced files in the drawing are recorded. All files will be 

displayed in a list and you are free to decide whether the files should be stored or not. 

Function 

When running Zip and Go you will now be asked whether you want to save the current drawing or 

not. This allow you to control which drawing status will be stored in the archive. 

 

You have two options for creating the Zip archive: 

 

The option Maintain directory structure captures the drawing file and all external files as they are 

and packs them in a Zip folder including the original directory structures. 

The option No directory structure also captures the drawing file and all external files but does not 

adopt the directory structure of the external files. Instead it places them next to the drawing file in 

the Zip folder. SPIRIT will inform you if this option causes duplicate names in the file and asks you to 

resolve the problem. 

Duplication of names (duplication of files) can occur if, for example, two symbols or components with 

the same name but different paths are used in the drawing. The duplicate files are also marked in red 

in the content tree. At this point you can also decide by activating or deactivating the check boxes 

which files should also be stored in the ZIP file. It is also recommended to check the duplicate files at 

this point to determine whether they really make sense in the drawing or whether they occur in the 

drawing due to inadvertent work steps and whether they should not generally be corrected in the 

drawing. 
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In addition to the Maintain directory structure function, you can also use Archiving additional 

embedded files. You can use this for output of the files embedded in the drawing, such as 

components, images or references, separately into the Zip archive. This option is only available in 

conjunction with Maintain directory structure. 

 

The latest innovation in Zip and Go relates to the Zip report. First of all, you are free to add an 

additional comment to the Zip archive. This annotation is entered in the annotation field provided 

and will be included in the report. 

 

The report can only be viewed before the Zip archive is created. 

For better documentation and traceability, the 

report now contains the SPIRIT version used 

and the creation date of the Zip archive, 

followed by the annotation and the path 

information for the main drawing and files. 

The report is saved as a log file in the Zip 

archive and can be opened using the text 

editor. 

 

 

 

Value 

 The current drawing status will be archived in the Zip folder. 
 Both the original folder structure and direct storage of the files in the Zip archive is possible. 
 Better documentation on the contents of the Zip file. 
 Notes on duplicate files in the drawing.  
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Adaptations – Import PDF file as vector file 

without text or with better pictures 

More influence or really sharp – what do you prefer? 

Description 

In order to import 2D basics for planning into SPIRIT, the PDF format plays the most important role 

for most users along with DWG / DXF files. SPIRIT offers the option of importing vector information. 

This has the advantage that you can snap on the drawing elements. Depending on how detailed the 

plan is, such an import can also slow down the workflow because the SPIRIT magnetic cursor will also 

snap on hatch lines or text. 

Therefore we have optimized the import function in SPIRIT to offer you more setting options for the 

conversion of PDF files. When converting to EMF, you have two options for converting, including 

influencing the text from the PDF file for the conversion to images. The resolution of the files to be 

imported can now be set and – most important – be increased. The imported image files allow you to 

work much smoother and faster. 

Function 

When converting the PDF file, you can choose from three 

methods with the new version. One way to convert the PDF 

to an image file and two types of conversion to create an 

EMF file with all vectors from the PDF. 

Settings for PDF files - conversion to image 

Under the tab Advanced settings for the conversion to JPEG 

Image File (*.JPG) you can set optimizations for the image 

size and the image quality. You can select a resolution (DPI) between 96 to 600 dpi for the conversion 

result. Previously the standard value was fixed to 96 dpi. With the Compression-Quality you can also 

influence how much the image should be compressed. The gradation is between 100 and 25. 

Settings for PDF files - conversion to EMF 

As already described, you can convert the PDF file to a vector reference (* .emf) using two different 

methods: 

 Vector reference (* .emf) - import mode 2019 

 Vector reference (* .emf) - import mode 2017 

The import results may differ depending on the process. PDF plans that are automatically generated 

from BIM models usually contain much more vectorized individual elements than conventional PDF 

files. It is therefore recommended to check the different procedures. 



SPIRIT 2020 – What´s new 

10 

 

For the variant Vector reference (* .emf) - import mode 2019, you will find options for handling the 

text display in the PDF file under the tab Advanced Settings. Since texts are not preserved as text in 

the converted PDF, these settings are used to reduce the vectors to be converted. 

 Ignore text 

The text in the PDF file will not be converted, this affects the conversion time and size of the 

* .emf file. 

 Simple representation 

The text will be adopted but converted to the standard Arial font. This may lead to deviations 

in the display. 

 Detailed presentation 

The text will be adopted and converted as best as possible based on the existing font. 

Value 

 Significantly higher quality when importing image files into SPIRIT. 

 Greater accuracy when acquiring dimensions from image files. 

 More flexible conversion options to vectors. 

 Smooth workflow.  
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Functions – Cutting and connecting polylines 

2D basics for SPIRIT 

Description 

When working with polylines, it often happens that the polylines have to be edited subsequently. 

SPIRIT 2020 offers the two new functions of cutting and connecting polylines. As you can already 

guess from the name, you can cut a closed polyline (Areas) with just a few clicks using a cutting line 

and reconnect adjacent polylines. 

Function 

The two functions are available in the Menu-Navigator via Drafting > F1 Polylines > F6 Edit> S3 

Cutting and S4 Connect and in the context menu of the polyline. The function calls can also be found 

under Customize > Classic menu. 

Cutting polylines 

After selecting the function, you will be asked to define a 

cutting line using two click points. Then, as usual, select the 

closed polylines via Entity, Group, Area to be separated by 

the section line.  

 

Connect polylines 

After selecting the function, you will be asked to select the 

basic polyline. Then, as usual, use Entity, Group, Area to 

select the other adjacent closed polylines that you want to 

merge. 

 

The basic polyline defines the properties. For example, color, layer, hatching, filling, etc. All other 

polylines that you then want to connect within the function are connected and displayed accordingly. 

Value 

 Fast editing of closed polylines. 
 Polylines can be cut or connected more precisely. 
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Functions – Explode 

One function – all entities. 

Description 

The function Explode was slightly revised for SPIRIT 2020. Previously there were different functions 

for each object to be exploded, the new function can be used for all objects and is therefore also 

stored centrally under Edit. 

Function 

You can find the new exlode function in the pull-down menu Edit > Explode and via the Menu-

Navigator > 2D Edit > S3 Explode. After selecting the function, simply select the objects that you want 

to explode via Entity, Group, Area, as usual with SPIRIT. 

The Explode menu allows you to choose what should happen to the contents of the self-reference in 

relation to the layer tray. If necessary, activate the option F8 Self reference to layer: 

 Active means that the content of the self-reference will be saved on the active layer. 

 Inactive means that the content ends up on the corresponding layer on which it was drawn. 

Value 

 One function for all objects. 

 More control when exploding self-references. 
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Functions – Align objects 

Move, copy, rotate and stretch – all in one function. 

Description 

This new function allows you to perform several work steps at 

once. You can move objects, rotate them directly and align them to 

another object. The function can be used for all common entities 

(symbols, lines, polylines, fills, hatching, texts, etc.) in SPIRIT. 

With additional settings, the objects can also be moved and 

rotated only or, for example, can also be placed as a copy and 

multiple copy. 

Function 

In the Menu-Navigator select 2D Edit > S2 Align to start the new function. You can also select the 

additional options S1 With resize, S2 And copy as well as S3 Multiple copies. The standard selection in 

SPIRIT F1 entities, F2 group and F3 area allows you to select one or more objects to be aligned. Now 

define the starting points and the corresponding target point. To rotate the object, define a second 

target point. Depending on the additionally set options, the object will also be resized based on the 

two defined target points. You can also copy the “final result” one or more times. 

Value 

 Several work steps are combined in the Align function. 

 Moving, rotating and stretching over two reference points simplifies operation. 

 The function can be used flexibly thanks to various additional functions. 
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Functions – Arrange objects  

All the way forward or all the way back – change the order of drawing for 

overlapping objects per layer. 

Description 

The order of drawing for objects is fundamentally influenced by the arrangement of the layers. SPIRIT 

offers the setting options for this under Drawing / System > F4 Layer Order > F1 to F3. The standard 

setting in SPIRIT is F3 in Order. 

But not all objects will always be drawn separately on different layers. For example, differently 

colored areas and labels must be drawn on one layer. The new functions allow you to specifically edit 

the order of drawing for the objects. 

 

 

Function 

The new Arrange function allows you to control overlapping objects on a slide that cover an area. For 

example objects such as lines, polylines, hatching and fillings, labels and pictures. The four new 

functions, which are called Draw order, offer you the following possibilities: 

 

The Draw order function can be found in the Menu-Navigator > 2D Edit > Move > S3 Draw order. To 

change the order of the objects, first select the desired function and then select the desired objects 

using the standard selection functions. You must also select a reference object for the element 

forward and element back options. In addition, the context menus of the objects line, polyline, text, 

text block, dimensioning contain the option Draw order when selection has already been made. 
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Patterns in groups 

The function of the groups will be considered when arranging the objects. If objects that belong to a 

group are selected, changing the drawing order will always affect the entire group. Optionally, 

groups can be exploded, this setting is selected by default, so that only the selected object(s) will be 

arranged accordingly. 

Example for a possible arrangement of the drawing order on a layer 

These functions allow you to choose which object should be displayed in front of or behind other 

objects. You can also specify the drawing order of different object types. 

 

Note 

The drawing order of overlapping objects can only be controlled within a layer and works only if the 

corresponding layer is active. 

Value 

 Objects can now be specifically changed in their order in the drawing area. 

 Expanding the functions and objects gives you a more flexible way of working. 

 The layout with the help of fillings, hatching and text etc. is simplified.  

Polyline with filling Polyline with filling 

Dimension 

Reference 

Polyline 

with 

hatching 

Text 

Text 

Line 
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Output – New print settings dialog 

Clearer plus more functions. 

Description 

When your work is finished, the plan serves for presentation, documentation and as a basis for 

execution on the construction site. This enables you to meet all requirements. This makes the output 

options the main topic in SPIRIT 2020. 

The Printer/Plotter settings dialog has now a much clearer structure and offers a complete overview 

of the options for the output of a plan. In particular, the settings for PDF output can now be clearly 

defined under the To PDF heading. You can also get from the dialog to the SPIRIT Settings > Drawing 

settings > Extended PDF parameters in order to define the PDF info for the drawing. 

You can open the dialog in SPIRIT 2020 in the following ways: Via the pull-down menu File > Print 

Setup and via the two standard workflows under the Menu-Navigator Sheets / Presentation > Plotter 

> Print Setup or by creating a new sheet under the dockable dialog Sheet Manager > add sheet. 

Function 

The Printer/Plotter settings dialog now shows all possible information and output settings directly. 

The new PDF settings refer to all variants of PDF output in the Sheets / Presentation menu.  

All other new functions for output are explained on the following pages in the “What´s new” 

document. 

Value 

 Clear dialog for all settings for print output, HPGL and PDF.  
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Output – New PDF output 

To PDF - the new standard in SPIRIT. 

Description 

Creating a PDF file is now a standard process in many offices and has become indispensable in 

everyday life. PDF stands for "Portable Document Format" and was developed by Adobe Systems in 

1993 as a platform-independent file format. The files can be opened on all computers, tablets and 

smartphones. A PDF can consist of text, vectors and images and looks the same on all systems.  

The PDF output has been completely revised for SPIRIT 2020 and offers you reliable and fast output 

options for everything you want to record in SPIRIT via the PDF file. 

Function 

First things first: The new PDF edition creates your PDF files faster. This is due to the optimizations 

for the new PDF output in SPIRIT 2020. Depending on the content, the PDF files generated are 

smaller than in version 2019. As you have already learned, the Printer/Plotter settings dialog has 

been cleaned up. The settings of the PDF output are clearly arranged there and have a direct impact 

on the PDF file to be created at this central point. All of the following settings for PDF output come 

into play when you use the SPIRIT function To PDF. 

Layer structure Active and Visible in PDF-File 

You are probably already familiar with this 

function from previous SPIRIT versions. Define 

whether the layers in the PDF should be active 

and whether the contents of the PDF file can be 

switched on and off. 

Include hyperlinks 

The hyperlinks of an object can optionally be 

stored in the PDF file. Decide whether the 

hyperlink to the respective object should be 

selectable in the PDF or not. 

Explode text into geometry 

One of the biggest innovations in version 2020 is the output of text (fonts) in the PDF file. This means 

that text in the PDF remains recognizable as text and that the corresponding font defined in SPIRIT 

will also be stored in the PDF file. This produces much smaller PDF files, especially if they contain 

sheets with a lot of text. The function Text explode to geometry allows you to control whether the 

text will be transferred as text into the PDF or should be exploded into geometry. 
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Open PDF file before saving 

The option to PDF reader has disappeared from the Menu-Navigator and moved to the new 

Printer/Plotter settings dialog as a user setting. When the function is active, SPIRIT creates a 

temporary PDF file with the name of the drawing and the active view or sheet. This makes it possible 

to create several temporary PDF files at the same time. However, you should consider that this PDF is 

only temporarily available in your PDF program. You have to save the file using your PDF program. 

Open PDF file after saving 

SPIRIT 2020 offers you the option of opening the PDF file directly after saving it in your PDF program. 

This is the PDF file which you have saved during the creation process. 

Extended PDF parameters 

The Extended PDF parameters are new in SPIRIT 

2020 and contain drawing-dependent 

information. Use the button Extended PDF 

parameters to access the SPIRIT Settings > 

Drawing settings > PDF Info. Here you can store 

standard information for the drawing, which is 

then included in the properties of the PDF file. 

You can enter the author, title, subject and 

keywords. 

 

What else is new? 

The new PDF output also comes with some user requests as you may already have recognized. The 

problems “PDF in Adobe Acrobat cannot be opened” or “Output with transparencies as an image 

file” were taken into account in the new edition and should be a thing of the past.  

Note: The previous settings for PDF output under Settings > Print Settings are no longer available in 

SPIRIT 2020. 

Value 

 SPIRIT creates smaller PDF files. 

 The creation of PDF files was accelerated. 

 Text remains in the PDF as text. 

 Layers can be switched in the PDF file. 

 Any number of PDF files can now be generated temporarily from SPIRIT. 

 Transparencies allow output as vectors. 

 PDF files can contain additional information about the author. 
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Output – Definition of the file name for file 

output       
Labeled correctly right from the beginning. 

Description 

The output issue includes not only printing on paper, but also general output to a file. With SPIRIT 

2020 we provide you with various variables that can be used to define the output name for all file 

formats depending on the drawing. 

Function 

You will find the new function in the SPIRIT 

settings under Drawing settings > Output 

settings > File name when printing to file. When 

you select it a list of the available variables 

appears on which you can double-click in the 

input line.  

The variables consist of date information, 

system information, view information and sheet 

information. In the input line, you also have the 

option of entering the separators. You decide 

individually how the file name will look at the 

end. 

  

Here is a small example with [_] as a separator: 

@ DWGNAME @ _ @ VIEWNAME @ _ @ LAYOUTID @ _ @ LAYOUTAUTHOR @ 

The Preview shows you a finished example of your currently open drawing 

Value 

 The output name can be composed of various variables. 

 The defined output name applies to all file formats. 

 The output name can be composed individually with additional characters.  
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Output – Target path: S12 or view and sheet 

Correctly stored.  

Description 

You will surely know the problem too. You open several drawings from different projects during a 

working day. For output you set a corresponding path for the PDF file. Then you save the PDF file, 

edit the drawing and continue work until it is time for output again. As you know SPIRIT always 

remembers the last path used and you have to change the project and set the path again. 

You may have been able to cure this problem by specifying a folder for general output in the SPIRIT 

settings so that all output files can be stored there. Certainly a solution that you can continue to use 

with SPIRIT 2020.  

Drawing-related output 

With SPIRIT 2020, the default storage path has changed. For each file output the program will first 

suggest the path of the S12 drawing. SPIRIT 2020 will save each generated file next to the drawing 

unless defined otherwise by you. So you can always be sure that the corresponding output will end 

up in the appropriate project folder for the drawing. 

There is more 

There is another innovation in the dockable dialogs View Manager and Sheet Manager. With SPIRIT 

2020, you can define a separate storage path for each plan and sheet. This path is saved as a relative 

path and is therefore also suitable for network storage or can be predefined in the default drawing 

for individual project structures. After the definition of the relative path, starting from the S12, the 

path will be displayed within two brackets () as an absolute path. 

Options in the SPIRIT settings  

You can determine your optimal output workflow using the SPIRIT option Save output files in the 

system path "Plot file" under System settings> Print settings. This setting is deactivated by default in 

version 2020 and thus the drawing-related storage takes effect. 

Function 

You can check the target directory for your output on the respective view or sheet under the General 

Info group. Depending on the output settings, you will see the relative path of the S12 or the 

individual relative path in front of the bracket and the absolute path in the bracket. 
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In the Target directory line on the respective view or sheet you can define the output path via         or 

enter it directly (copy and paste). The changes to the path can also easily and conveniently be applied 

to multiple views and sheets using multi-selection of the lines. 

If you want to work with a fixed path for your output as before and have set the desired path via the 

System settings > Path settings, the path will also be displayed on the view or sheet. 

Attention: for the option System settings > Plotter settings the function Save output files in the 

system path "Plot file" must be activated. 

 

It is not possible to change the path at this point if the setting Save output files in the system path 

"Plot file" is active. 

Value 

 All file outputs are initially located next to the S12 and saved with the project. 

 Individual project storage for output files for each project. 

 Individual output per view and sheet can be set. 

 Individual paths for output via Sheets / Presentation can be set as relative paths. 
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Output – Print Server 2.0 

Your output is in safe hands. 

Description 

Many tasks during project planning are repetitive and some of them are also very time-consuming. 

This applies, for example, to the output of plans and drawing exchange with other planning 

participants. Sheets/Plans must still be printed or plotted in order to discuss them at the construction 

site or with the client. At the same time, files for data exchange have to be created as DWG/DXF files 

to give them to specialist planners. Last but not least PDF documents play a major role. All of these 

steps have to be carried out over and over again for a complete project: floor plans, views and 

sections, overview plans, details etc. and this has to be done for every new planning status. Since 

version SPIRIT 2012 pro you can use the Print Server for these tasks. 

The new version SPIRIT 2020 includes the Print Server 2.0 which enables you to perform these tasks 

much faster. One of the most important aspects is the flexible use of the new print server. No matter 

how complex or simple the output will be, the new print server helps you to optimize and accelerate 

your work process. It will become your central tool for the output of plans, PDF and DXF files. 

The new look and the new functions of the print server do not only manage the views and sheets 

more clearly and easily, in addition, you can now see all the important information about the 

individual plans directly. Furthermore, you can also output different file formats individually and 

automatically using one function only. 

Function 

Start the print server via the pull-down menu File > Print server or via the Menu Navigator > Sheets / 

Presentation> S0 Print Server. 
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The print server shows you the views and sheets of the opened drawing. For every view/sheet in the 

active drawing all important information about the drawing and the output will be displayed. You can 

also show and hide the columns you want and save them as your layout. 

Status and status message  

In SPIRIT 2020 the print server shows the status of the respective 

view and sheet. Are the printer settings all set correctly? You can 

now view this and know exactly whether you need to change 

settings for the respective view or sheet. 

 

 

 

An overview of more information 

 

You can now display all of the entries for the plan that you define in the dockable dialogs View 

Manager and Sheet Manager in the Print Server. This enables you to see at a glance which plan 

information is missing or entered incorrectly, but also which plan with the respective contents should 

be used for output. In addition, you can see directly which information is included in the target 

name. 

Several drawings in the print server 

After starting the new print server the views and sheets of the currently active drawing will be 

displayed. You can also use the Add drawing function to open additional drawings if you need 

another view or sheet. SPIRIT then opens the drawing in the background and displays the list of views 

and sheets. 
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Print jobs 

Of course, you still have the option to create and save print jobs from several drawings or for the 

current drawing. New in version 2020: only one print job can be loaded at a time.  

However, this offers you the advantage to save and load the print job for each project in the project 

folder or anywhere you want. If a loaded print job contains drawings that are not currently open, 

SPIRIT will notify you and, if necessary, open all drawings which are required to execute the print job. 

Value 

 The print server always loads the current drawing directly and clearly shows the views and 

sheets. 

 The print server reads out the print settings and displays the corresponding status with a note. 

 The print server clearly shows the contents of the views and sheets. 

 The storage location is taken from the specified target directory. 

 The target name is taken from the defined output names. 

 Print jobs can be saved with the project. 
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Output – Extensions at the locate plot sheet 

Faster adjustments to the Quick Layout function. 

Description 

In order to position the selected sheet in the drawing area the so-called layout plot sheet will be laid 

over the content of the plan. The plot sheet includes the previously selected sheet size and depends 

on the scale. When the layout plot sheet is attached to the cursor you can directly influence these 

two factors (sheet size and scale). 

If one of your previous settings was not matching, you do not have to reset everything. You can make 

all changes directly using the new functions of the Menu Navigator. 

The layout plot sheet adapts dynamically to the cursor and the info line shows you the modified 

sheet sizes or the modified scale. 

Function 

In the Menu Navigator under S9 Plotter > F10 Quick Layout you can access the corresponding 

function for inserting the layout plot sheet. The defined plot sheet depends on the cursor. The 

following new functions are now available in the Menu Navigator. 

F9 Previous Plot Scale and F10 Next Plot Scale allow you to change the set 

scale directly. The layout plot sheet attached to the cursor adapts 

accordingly. 

F7 sheets larger and F8 sheets smaller allows you to switch the sheet sizes of 

the selected printer in ascending or descending order. 

The info line shows you the sheet size currently attached to the cursor. 

Value 

 The ability to change the scale and sheet size at any time while setting the layout plot sheet saves 

time and makes working much easier. 


